Linksys WRT AC3200

Matthew B. 13/04/2019
I have only had this router 1 day but I did get it to work on Vodafone FibreX with no issues. Just some small knowledge of how to SSH into the router is needed.

When you get the router - before you set it up - download the latest firmware from Linksys and save it to your PC.

Plug in the router and connect your PC/Laptop to the router with Ethernet. Navigate to 192.168.1.1 .. Set a password and skip the internet setup.
Navigate to the Router Administration page and select the firmware you downloaded previously. Choose file and upload. The reason you need to do this is that the older firmware that comes on the device seemed to have a weird network config to begin with.

Then you will need to SSH into the router.
Mac already has this built in - for windows you can use putty.

do

ssh root@192.168.1.1

Type
vi /etc/config/network

This is using VIM editor - If you don't know how to use VIM then have a quick look at this https://www.openvim.com/

but basically when it is loaded - use the up down left right arrows to navigate around. Press i to start typing. Press ESC to stop typing.

change these sections

config interface 'wan'
option proto 'dhcp'
option ifname 'eth0.2'

config interface 'wan6'
option proto 'dhcpv6'
option ifname 'eth0.2'

to

config interface 'wan'
option proto 'dhcp'
option ifname 'eth0.10'

config interface 'wan6'
option proto 'dhcpv6'
option ifname 'eth0.10'

(basically the 2 has been changed to 10 which is the VLAN ID that vodafone requires).

Then change this section

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '4 5'

to 

config switch_vlan
option device 'switch0'
option vlan '10'
option ports '4t 5t'

(This basically tags ports 4 and 5 with the VLAN tag of 10). (I'm not sure where why it is port 4 and 5).

When it all looks correct Press : then wq to quit and save.

Then type

/etc/init.d/network restart

Go back to the web portal and you should be connected to the internet.

After 1 day of use - seems to have strong WIFI signal. My last netgear router 5g didn't even get halfway through my house, but now I get 50% signal at the end of the house which is nice. GUI is nice and snappy. This has absolutely great hardware.

vigor: Linksys/WrtAc3200 (last edited 2019-04-28 06:11:40 by PieterSmit)