Differences between revisions 8 and 10 (spanning 2 versions)
Revision 8 as of 2014-09-24 07:33:24
Size: 401
Editor: JDutcher
Comment:
Revision 10 as of 2015-07-01 11:49:30
Size: 1490
Editor: PieterSmit
Comment: Link to bgp routing example.
Deletions are marked like this. Additions are marked like this.
Line 1: Line 1:
Hi, everybody! My name is Pansy. <<BR>>
It is a little about myself: I live in Germany, my city of Berlin Spandau. <<BR>>
It's called often Northern or cultural capital of BE. I've married 1 years ago.<<BR>>
I have two children - a son (Javier) and the daughter (Edwina). We all like Disc golf.<<BR>>
<<BR>>
Check out my homepage [[http://balkanstuebchen.de/index.php/gaestebuch?t=0|idm crack]]
##master-page:HomepageReadWritePageTemplate
##master-date:Unknown-Date
#format wiki
#language en
= VRF =
 * Visualizing a router. This is not about MPLS, although that is where the VRF concept comes from.
 * http://www.shafagh.net/2009/10/vrf-lite.html
 * Example of routing beteen vrf-light using BTP http://packetlife.net/blog/2010/mar/29/inter-vrf-routing-vrf-lite/

 * Once a router has VRF software the interface must be upgraded to support VRF.
   {{{
      (config)#vrf upgrade-cli
   }}}

 * Sample Switch config with bgp and vrf.
{{{
Switch(config)# router bgp 800
Switch(config-router)# address-family ipv4 vrf vl2
Switch(config-router-af)# redistribute ospf 2 match internal
Switch(config-router-af)# neighbor 83.0.0.3 remote-as 100
Switch(config-router-af)# neighbor 83.0.0.3 activate
Switch(config-router-af)# network 8.8.2.0 mask 255.255.255.0
Switch(config-router-af)# exit
}}}

== OSPF problems ==
 * Experienced problems where a router, connected to service provider MPLS using ospf area x, running vrf-lite, and connecting to area 0 on internal network would not show the area 0 routes.
   * Problem was caused by ospf superbackbone rules that kicked in due to putting the ospf instance in a vrf
   * Solution under ospf instance use command #capability vrf-lite
 * [[https://www.racf.bnl.gov/Facility/TechnologyMeeting/Archive/06-30-04-CISCO/Using-OSPF-in-MPLS-VPN-Environment.pdf|Ospf in MPLS VPN environment.]]
...
----
CategoryCisco

VRF

Switch(config)# router bgp 800
Switch(config-router)# address-family ipv4 vrf vl2
Switch(config-router-af)# redistribute ospf 2 match internal
Switch(config-router-af)# neighbor 83.0.0.3 remote-as 100
Switch(config-router-af)# neighbor 83.0.0.3 activate
Switch(config-router-af)# network 8.8.2.0 mask 255.255.255.0
Switch(config-router-af)# exit

OSPF problems

  • Experienced problems where a router, connected to service provider MPLS using ospf area x, running vrf-lite, and connecting to area 0 on internal network would not show the area 0 routes.
    • Problem was caused by ospf superbackbone rules that kicked in due to putting the ospf instance in a vrf
    • Solution under ospf instance use command #capability vrf-lite
  • Ospf in MPLS VPN environment.

...


CategoryCisco

cisco/VRF (last edited 2015-07-01 11:49:30 by PieterSmit)