Differences between revisions 1 and 9 (spanning 8 versions)
Revision 1 as of 2010-06-23 06:39:50
Size: 371
Editor: PieterSmit
Comment:
Revision 9 as of 2014-10-03 08:22:47
Size: 1375
Editor: PieterSmit
Comment:
Deletions are marked like this. Additions are marked like this.
Line 5: Line 5:
= VRF =  = VRF =
Line 7: Line 7:
 * http://www.shafagh.net/2009/10/vrf-lite.html

Line 12: Line 15:
 * Sample Switch config with bgp and vrf.
{{{
Switch(config)# router bgp 800
Switch(config-router)# address-family ipv4 vrf vl2
Switch(config-router-af)# redistribute ospf 2 match internal
Switch(config-router-af)# neighbor 83.0.0.3 remote-as 100
Switch(config-router-af)# neighbor 83.0.0.3 activate
Switch(config-router-af)# network 8.8.2.0 mask 255.255.255.0
Switch(config-router-af)# exit
}}}

== OSPF problems ==
 * Experienced problems where a router, connected to service provider MPLS using ospf area x, running vrf-lite, and connecting to area 0 on internal network would not show the area 0 routes.
   * Problem was caused by ospf superbackbone rules that kicked in due to putting the ospf instance in a vrf
   * Solution under ospf instance use command #capability vrf-lite
 * [[https://www.racf.bnl.gov/Facility/TechnologyMeeting/Archive/06-30-04-CISCO/Using-OSPF-in-MPLS-VPN-Environment.pdf|Ospf in MPLS VPN environment.]]

VRF

  • Visualizing a router. This is not about MPLS, although that is where the VRF concept comes from.
  • http://www.shafagh.net/2009/10/vrf-lite.html

  • Once a router has VRF software the interface must be upgraded to support VRF.
    •       (config)#vrf upgrade-cli
  • Sample Switch config with bgp and vrf.

Switch(config)# router bgp 800
Switch(config-router)# address-family ipv4 vrf vl2
Switch(config-router-af)# redistribute ospf 2 match internal
Switch(config-router-af)# neighbor 83.0.0.3 remote-as 100
Switch(config-router-af)# neighbor 83.0.0.3 activate
Switch(config-router-af)# network 8.8.2.0 mask 255.255.255.0
Switch(config-router-af)# exit

OSPF problems

  • Experienced problems where a router, connected to service provider MPLS using ospf area x, running vrf-lite, and connecting to area 0 on internal network would not show the area 0 routes.
    • Problem was caused by ospf superbackbone rules that kicked in due to putting the ospf instance in a vrf
    • Solution under ospf instance use command #capability vrf-lite
  • Ospf in MPLS VPN environment.

...


CategoryCisco

cisco/VRF (last edited 2015-07-01 11:49:30 by PieterSmit)