Differences between revisions 1 and 7 (spanning 6 versions)
Revision 1 as of 2012-10-20 08:16:08
Size: 1656
Editor: dsl-244-102-175
Comment: Create initial config, still need to cleanup
Revision 7 as of 2012-10-20 13:06:18
Size: 3212
Editor: PieterSmit
Comment: Correct ospf priority's
Deletions are marked like this. Additions are marked like this.
Line 20: Line 20:
 ip nat outside
Line 42: Line 41:
 ip address 10.202.191.101 255.255.255.0  ip address 10.202.191.143 255.255.255.0
Line 47: Line 46:
 ip nhrp registration no-unique
Line 48: Line 48:
 ip ospf flood-reduction
 ip ospf priority 0
Line 53: Line 55:
 ip address 10.202.192.101 255.255.255.0  ip address 10.202.192.143 255.255.255.0
Line 58: Line 60:
 ip nhrp registration no-unique
Line 59: Line 62:
 ip ospf flood-reduction
 ip ospf priority 0
Line 67: Line 72:
line 0/3/0
 script dialer gsm
 no exec
 rxspeed 7200000
 txspeed 2000000
!
router ospf 1
 network 10.202.191.0 0.0.0.255 area 0
 network 10.202.192.0 0.0.0.255 area 0
!
Line 68: Line 83:
    }}}

 * Core routers, can be one or two routers, external IP's nated to 10.10.240.191 & 192
   {{{
!
interface Loopback191
 description TunnelSRC-nat-{{IP-EXT-NAT-WWW1}}
 ip address 10.10.240.191 255.255.255.255
!
interface Loopback192
 description TunnelSRC-nat-{{IP-EXT-NAT-WWW2}}
 ip address 10.10.240.192 255.255.255.255
!
interface Tunnel191
 description 3G-ExtIP-{{IP-EXT-NAT-WWW1}}
 ip address 10.202.191.1 255.255.255.0
 no ip redirects
 ip nhrp group 191
 ip nhrp map multicast dynamic
 ip nhrp network-id 191
 ip ospf network broadcast
 ip ospf flood-reduction
 ip ospf priority 191
 tunnel source Loopback191
 tunnel mode gre multipoint
!
interface Tunnel192
 description 3G-ExtIP-{{IP-EXT-NAT-WWW2}}
 ip address 10.202.192.1 255.255.255.0
 no ip redirects
 ip nhrp group 192
 ip nhrp map multicast dynamic
 ip nhrp network-id 192
 ip ospf network broadcast
 ip ospf flood-reduction
 ip ospf priority 192
 tunnel source Loopback192
 tunnel mode gre multipoint
!
router ospf 1
 network 10.202.0.0 0.0.255.255 area 0
!

   }}}

== Comments ==
 * Feel free to leave comments or corrections.
 * 2012-10-20 Pieter Smit - Create page.
Line 69: Line 132:
Page hits:<<Hits>>
----
CategoryCisco

Cisco 3G GSM + GRE Config

  • Cisco/Gsm3G/Old2012 Older config with dialer, dialer not needed

  • 3G Cisco router config
    • Details:
      • 2 - WWW GW IP's with gre tunnels
      • Use subnet 10.202.191.x and 10.202.192.x for tunnel termination. .1 IS HQ GW
      !
      chat-script gsm "" "ATD*99*1#" TIMEOUT 60 CONNECT
      !
      !
      interface Cellular0/3/0
       ip address negotiated
       no ip virtual-reassembly in
       encapsulation ppp
       dialer in-band
       dialer idle-timeout 0
       dialer string gsm
       dialer-group 1
       async mode interactive
       ppp authentication chap callin
       ppp chap hostname dummy
       ppp chap password 0 dummy 
       ppp ipcp dns request
       ppp ipcp address accept
      !
      ! ##Dual Antenna HWIC##
      interface Cellular0/3/1
       no ip address
       encapsulation ppp
      !
      !
      interface Tunnel191
       description 3G-GRE
       ip address 10.202.191.143 255.255.255.0
       ip nhrp group 191
       ip nhrp map multicast 10.202.191.1
       ip nhrp network-id 191
       ip nhrp nhs 10.202.191.1
       ip nhrp registration no-unique
       ip ospf network broadcast
       ip ospf flood-reduction
       ip ospf priority 0
       tunnel source Cellular0/3/0
       tunnel destination {{IP-EXT-NAT-WWW1}}
      !
      interface Tunnel192
       description 3G-GRE-IS
       ip address 10.202.192.143 255.255.255.0
       ip nhrp group 192
       ip nhrp map multicast 10.202.192.1
       ip nhrp network-id 192
       ip nhrp nhs 10.202.192.1
       ip nhrp registration no-unique
       ip ospf network broadcast
       ip ospf flood-reduction
       ip ospf priority 0
       tunnel source Cellular0/3/0
       tunnel destination {{IP-EXT-NAT-WWW2}}
      !
      ip route {{IP-EXT-NAT-WWW1}} 255.255.255.255 Cellular0/3/0
      ip route {{IP-EXT-NAT-WWW2}} 255.255.255.255 Cellular0/3/0
      !
      dialer-list 98 protocol ip permit
      !
      line 0/3/0
       script dialer gsm
       no exec
       rxspeed 7200000
       txspeed 2000000
      !
      router ospf 1
       network 10.202.191.0 0.0.0.255 area 0
       network 10.202.192.0 0.0.0.255 area 0
      !
  • Core routers, can be one or two routers, external IP's nated to 10.10.240.191 & 192

    • !
      interface Loopback191
       description TunnelSRC-nat-{{IP-EXT-NAT-WWW1}}
       ip address 10.10.240.191 255.255.255.255
      !
      interface Loopback192
       description TunnelSRC-nat-{{IP-EXT-NAT-WWW2}}
       ip address 10.10.240.192 255.255.255.255
      !
      interface Tunnel191
       description 3G-ExtIP-{{IP-EXT-NAT-WWW1}}
       ip address 10.202.191.1 255.255.255.0
       no ip redirects
       ip nhrp group 191
       ip nhrp map multicast dynamic
       ip nhrp network-id 191
       ip ospf network broadcast
       ip ospf flood-reduction
       ip ospf priority 191
       tunnel source Loopback191
       tunnel mode gre multipoint
      !
      interface Tunnel192
       description 3G-ExtIP-{{IP-EXT-NAT-WWW2}}
       ip address 10.202.192.1 255.255.255.0
       no ip redirects
       ip nhrp group 192
       ip nhrp map multicast dynamic
       ip nhrp network-id 192
       ip ospf network broadcast
       ip ospf flood-reduction
       ip ospf priority 192
       tunnel source Loopback192
       tunnel mode gre multipoint
      !
      router ospf 1
       network 10.202.0.0 0.0.255.255 area 0
      !

Comments

  • Feel free to leave comments or corrections.
  • 2012-10-20 Pieter Smit - Create page.

... Page hits:1105


CategoryCisco

Cisco/Gsm3G (last edited 2017-11-10 22:37:27 by PieterSmit)