Differences between revisions 1 and 29 (spanning 28 versions)
Revision 1 as of 2012-10-20 08:16:08
Size: 1656
Editor: dsl-244-102-175
Comment: Create initial config, still need to cleanup
Revision 29 as of 2017-11-10 22:37:27
Size: 5667
Editor: PieterSmit
Comment:
Deletions are marked like this. Additions are marked like this.
Line 6: Line 6:
 * [[Cisco/Gsm4GLTE]]
 * [[Cisco/Gsm3G/EEMreset]] - Automated 3G modem reset on cisco router.
 * [[Cisco/Gsm3G/ServiceError]] - !ServiceError
Line 7: Line 10:
 * Need to add IPSec see [[http://www.cisco.com/en/US/docs/ios-xml/ios/sec_conn_ike2vpn/configuration/15-2mt/sec-flex-spoke.html]]
Line 8: Line 12:
 * Cisco 3G cellular modem reset / power-cycle
   * If command not available it could be that modem firmware is to old.
   * {{{ #test cellular 0/3/0 modem-power-cycle }}}
 * Also resets the modem.
   * {{{ #cellular 0/3/0 gsm prl-region 0 }}}

 * Cisco 3G cellular - Firmware - NOT included with IOS on HWIC module download seperate extract .tar to flash
   * 201303 - latest firmware for Europe 8790_k2_0_7_52.tar
   * 201410 - check modem model with #show inventory
  
   * {{{
        archive tar /xtract "source-url" flash:
        microcode reload cellular pa-bay slot gsm modem-provision
        !Cellular interface will shut and no shut automatically. It can take long but runs in background.
     }}}
Line 12: Line 31:
     * Use subnet 10.202.191.x and 10.202.192.x for tunnel termination. .1 IS HQ GW      * Example: Use subnet 10.202.191.x and 10.202.192.x for tunnel termination. .1 IS HQ GW
Line 15: Line 34:
chat-script gsm "" "ATD*99*1#" TIMEOUT 60 CONNECT chat-script gsm "" "ATD*99*1#" TIMEOUT 60 CONNECT
chat-script gsm+ "" "AT!SCACT=1,1" TIMEOUT 60 "OK"
!!! AT!SCACT=1,<profile_number>..."OK" (HSPA+ modem)
Line 20: Line 41:
 ip nat outside
Line 26: Line 46:
 dialer-group 1  dialer-group 98
Line 33: Line 53:
 ppp timeout 600
Line 42: Line 63:
 ip address 10.202.191.101 255.255.255.0  bandwidth 100
ip address 10.202.191.143 255.255.255.0
Line 47: Line 69:
 ip nhrp registration no-unique
Line 48: Line 71:
 ip ospf flood-reduction
 ip ospf priority 0
 tunnel path-mtu-discovery
 tunnel path-mtu-discovery age-timer 30
 tunnel path-mtu-discovery min-mtu 1300
Line 53: Line 81:
 ip address 10.202.192.101 255.255.255.0  bandwidth 100
ip address 10.202.192.143 255.255.255.0
Line 58: Line 87:
 ip nhrp registration no-unique
Line 59: Line 89:
 ip ospf flood-reduction
 ip ospf priority 0
 tunnel path-mtu-discovery
 tunnel path-mtu-discovery age-timer 30
 tunnel path-mtu-discovery min-mtu 1300
Line 67: Line 102:
line 0/3/0
 script dialer gsm
 no exec
 rxspeed 7200000
 txspeed 2000000
!
router ospf 1
 network 10.202.191.0 0.0.0.255 area 0
 network 10.202.192.0 0.0.0.255 area 0
!
Line 68: Line 113:
    }}}

 * Core routers, can be one or two routers, external IP's nated to 10.10.240.191 & 192
   {{{
!
interface Loopback191
 description TunnelSRC-nat-{{IP-EXT-NAT-WWW1}}
 ip address 10.10.240.191 255.255.255.255
!
interface Loopback192
 description TunnelSRC-nat-{{IP-EXT-NAT-WWW2}}
 ip address 10.10.240.192 255.255.255.255
!
interface Tunnel191
 description 3G-ExtIP-{{IP-EXT-NAT-WWW1}}
 ip address 10.202.191.1 255.255.255.0
 no ip redirects
 ip nhrp group 191
 ip nhrp map multicast dynamic
 ip nhrp network-id 191
 ip ospf network broadcast
 ip ospf flood-reduction
 ip ospf priority 191
 tunnel source Loopback191
 tunnel mode gre multipoint
!
interface Tunnel192
 description 3G-ExtIP-{{IP-EXT-NAT-WWW2}}
 ip address 10.202.192.1 255.255.255.0
 no ip redirects
 ip nhrp group 192
 ip nhrp map multicast dynamic
 ip nhrp network-id 192
 ip ospf network broadcast
 ip ospf flood-reduction
 ip ospf priority 192
 tunnel source Loopback192
 tunnel mode gre multipoint
!
router ospf 1
 network 10.202.0.0 0.0.255.255 area 0
!

   }}}

 * 2013 - put cellular network interface in own vrf.
   {{{
!
vrf definition vrf3gAPN
  rd 10.202.194.1:134
  !
  address-family ipv4
  exit-address-family
!
interface Tunnel194
  tunnel vrf vrf3gAPN
!
interface Cellular0/3/0
  vrf forwarding vrf3gAPN
!
no ip route 10.10.240.194 255.255.255.255 Cellular0/3/0 permanent name 3G-Central-APN-LB
ip route vrf vrf3gAPN 10.10.240.194 255.255.255.255 Cellular0/3/0 permanent name 3G-Central-APN-LB
!
  }}}

 * IP SLA ping to force traffic on static route to bring-up Cellular to get IP to bring up Tunnel.
{{{
ip sla 191
!! Older routers #rtr or #ip sla monitor !!
  icmp-echo 10.10.240.191
  tag 3G-tun191
  frequency 600
ip sla schedule 193 life forever start-time now

}}}


== Comments ==
 * Feel free to leave comments or corrections.
 * 2013-01-21 Pieter Smit - chicken egg problem where tunnel down because no source IP on cellular, and cellular down due to no interesting traffic.
   * Two solutions possible, [1.] Fix ip on cellular (works for private apn with fixed ip's) or [2.] ip sla to ping static route to force cellular0/3/0 up.
 * 2012-10-20 Pieter Smit - Create page.
Line 69: Line 196:

----
CategoryCisco

Cisco 3G GSM + GRE Config

  • Cisco/Gsm4GLTE

  • Cisco/Gsm3G/EEMreset - Automated 3G modem reset on cisco router.

  • Cisco/Gsm3G/ServiceError - ServiceError

  • Cisco/Gsm3G/Old2012 Older config with dialer, dialer not needed

  • Need to add IPSec see http://www.cisco.com/en/US/docs/ios-xml/ios/sec_conn_ike2vpn/configuration/15-2mt/sec-flex-spoke.html

  • Cisco 3G cellular modem reset / power-cycle
    • If command not available it could be that modem firmware is to old.
    •  #test cellular 0/3/0 modem-power-cycle 

  • Also resets the modem.
    •  #cellular 0/3/0 gsm prl-region 0 

  • Cisco 3G cellular - Firmware - NOT included with IOS on HWIC module download seperate extract .tar to flash
    • 201303 - latest firmware for Europe 8790_k2_0_7_52.tar
    • 201410 - check modem model with #show inventory
    •         archive tar /xtract "source-url" flash: 
              microcode reload cellular pa-bay slot gsm modem-provision
              !Cellular interface will shut and no shut automatically.  It can take long but runs in background. 
  • 3G Cisco router config
    • Details:
      • 2 - WWW GW IP's with gre tunnels
      • Example: Use subnet 10.202.191.x and 10.202.192.x for tunnel termination. .1 IS HQ GW
      !
      chat-script gsm  "" "ATD*99*1#"    TIMEOUT 60 CONNECT
      chat-script gsm+ "" "AT!SCACT=1,1" TIMEOUT 60 "OK"
      !!! AT!SCACT=1,<profile_number>..."OK" (HSPA+ modem) 
      !
      !
      interface Cellular0/3/0
       ip address negotiated
       no ip virtual-reassembly in
       encapsulation ppp
       dialer in-band
       dialer idle-timeout 0
       dialer string gsm
       dialer-group 98
       async mode interactive
       ppp authentication chap callin
       ppp chap hostname dummy
       ppp chap password 0 dummy 
       ppp ipcp dns request
       ppp ipcp address accept
       ppp timeout 600
      !
      ! ##Dual Antenna HWIC##
      interface Cellular0/3/1
       no ip address
       encapsulation ppp
      !
      !
      interface Tunnel191
       description 3G-GRE
       bandwidth 100
       ip address 10.202.191.143 255.255.255.0
       ip nhrp group 191
       ip nhrp map multicast 10.202.191.1
       ip nhrp network-id 191
       ip nhrp nhs 10.202.191.1
       ip nhrp registration no-unique
       ip ospf network broadcast
       ip ospf flood-reduction
       ip ospf priority 0
       tunnel path-mtu-discovery
       tunnel path-mtu-discovery age-timer 30
       tunnel path-mtu-discovery min-mtu 1300
       tunnel source Cellular0/3/0
       tunnel destination {{IP-EXT-NAT-WWW1}}
      !
      interface Tunnel192
       description 3G-GRE-IS
       bandwidth 100
       ip address 10.202.192.143 255.255.255.0
       ip nhrp group 192
       ip nhrp map multicast 10.202.192.1
       ip nhrp network-id 192
       ip nhrp nhs 10.202.192.1
       ip nhrp registration no-unique
       ip ospf network broadcast
       ip ospf flood-reduction
       ip ospf priority 0
       tunnel path-mtu-discovery
       tunnel path-mtu-discovery age-timer 30
       tunnel path-mtu-discovery min-mtu 1300
       tunnel source Cellular0/3/0
       tunnel destination {{IP-EXT-NAT-WWW2}}
      !
      ip route {{IP-EXT-NAT-WWW1}} 255.255.255.255 Cellular0/3/0
      ip route {{IP-EXT-NAT-WWW2}} 255.255.255.255 Cellular0/3/0
      !
      dialer-list 98 protocol ip permit
      !
      line 0/3/0
       script dialer gsm
       no exec
       rxspeed 7200000
       txspeed 2000000
      !
      router ospf 1
       network 10.202.191.0 0.0.0.255 area 0
       network 10.202.192.0 0.0.0.255 area 0
      !
  • Core routers, can be one or two routers, external IP's nated to 10.10.240.191 & 192

    • !
      interface Loopback191
       description TunnelSRC-nat-{{IP-EXT-NAT-WWW1}}
       ip address 10.10.240.191 255.255.255.255
      !
      interface Loopback192
       description TunnelSRC-nat-{{IP-EXT-NAT-WWW2}}
       ip address 10.10.240.192 255.255.255.255
      !
      interface Tunnel191
       description 3G-ExtIP-{{IP-EXT-NAT-WWW1}}
       ip address 10.202.191.1 255.255.255.0
       no ip redirects
       ip nhrp group 191
       ip nhrp map multicast dynamic
       ip nhrp network-id 191
       ip ospf network broadcast
       ip ospf flood-reduction
       ip ospf priority 191
       tunnel source Loopback191
       tunnel mode gre multipoint
      !
      interface Tunnel192
       description 3G-ExtIP-{{IP-EXT-NAT-WWW2}}
       ip address 10.202.192.1 255.255.255.0
       no ip redirects
       ip nhrp group 192
       ip nhrp map multicast dynamic
       ip nhrp network-id 192
       ip ospf network broadcast
       ip ospf flood-reduction
       ip ospf priority 192
       tunnel source Loopback192
       tunnel mode gre multipoint
      !
      router ospf 1
       network 10.202.0.0 0.0.255.255 area 0
      !
  • 2013 - put cellular network interface in own vrf.
    • !
      vrf definition vrf3gAPN
        rd 10.202.194.1:134
        !
        address-family ipv4
        exit-address-family
      !
      interface Tunnel194
        tunnel vrf vrf3gAPN
      !
      interface Cellular0/3/0
        vrf forwarding vrf3gAPN
      !
      no ip route           10.10.240.194 255.255.255.255 Cellular0/3/0 permanent name 3G-Central-APN-LB
      ip route vrf vrf3gAPN 10.10.240.194 255.255.255.255 Cellular0/3/0 permanent name 3G-Central-APN-LB
      !
  • IP SLA ping to force traffic on static route to bring-up Cellular to get IP to bring up Tunnel.

ip sla 191
!! Older routers #rtr  or #ip sla monitor !! 
  icmp-echo 10.10.240.191
  tag 3G-tun191
  frequency 600
ip sla schedule 193 life forever start-time now

Comments

  • Feel free to leave comments or corrections.
  • 2013-01-21 Pieter Smit - chicken egg problem where tunnel down because no source IP on cellular, and cellular down due to no interesting traffic.
    • Two solutions possible, [1.] Fix ip on cellular (works for private apn with fixed ip's) or [2.] ip sla to ping static route to force cellular0/3/0 up.
  • 2012-10-20 Pieter Smit - Create page.

...


CategoryCisco

Cisco/Gsm3G (last edited 2017-11-10 22:37:27 by PieterSmit)