Differences between revisions 1 and 17 (spanning 16 versions)
Revision 1 as of 2010-07-27 13:23:15
Size: 1319
Editor: PieterSmit
Comment:
Revision 17 as of 2012-10-20 07:59:34
Size: 3656
Editor: dsl-244-102-175
Comment: Update to modern config with no dialer
Deletions are marked like this. Additions are marked like this.
Line 1: Line 1:
## page was renamed from Cisco/Gsm3G
Line 6: Line 7:
 * [[GSMrouters]]
Line 7: Line 9:
   * http://www.google.co.za/search?hl=en&safe=off&q=tender+sample+documentation&aq=f&aqi=&aql=&oq=&gs_rfai=
Line 8: Line 11:
 * Cisco Commands
   {{{
       #sh cellular 0/3/0 security
       #cellular 0/3/0 gsm sim unlock {PIN}
       >> To store the SIM CHV1 code for verification, use the # gsm sim authenticate <pin>
       
   }}}
 *
   {{{
    #cellular <x/x/x> gsm profile create <profile number> <APN-AccessPointName> ipv4
    ! e.g.
    #cellular 0/3/0 gsm profile create 1 APNname ipv4
   }}}
 * debug chat
   {{{
   #debug chat
   #start-chat gsm 0/3/0
   #sh cellular 0/3/0 network
   #sh cellular 0/3/0 radio
   }}}
{{{
Line 10: Line 34:
!
!
interface Cellular0/3/0
 ip address negotiated
 encapsulation ppp
 dialer in-band
 dialer pool-member 98
 ppp ipcp address accept
!
!
line 0/3/0
 script dialer gsm
 no exec
 speed 384000
Line 29: Line 67:
!
interface Cellular0/2/0
 ip address negotiated
 encapsulation ppp
 dialer in-band
 dialer pool-member 98
 ppp ipcp address accept
!
!
line 0/2/0
 script dialer gsm
 no exec
 speed 384000
!

#dialer-list 98 protocol ip permit
Line 55: Line 81:
 ppp authentication chap optional  !!!! ppp authentication chap optional
Line 61: Line 87:
}}}
Line 62: Line 89:
 * debug
{{{
  debup chat
  debug ppp negotiation
  debug ppp event
  debug ppp error
}}}

 * Next example
{{{
!
track 1 interface Serial0/1/0 line-protocol
 delay up 180
pseudowire-class isgsm
 encapsulation l2tpv2
 ip local interface Cellular0/2/0
!
!
interface Tunnel203
 ip address 10.202.96.143 255.255.240.0
 no ip redirects
 ip mtu 1440
 ip nhrp authentication cl20280
 ip nhrp map multicast dynamic
 ip nhrp map 10.202.96.1 10.202.240.3
 ip nhrp map multicast 10.202.240.2
 ip nhrp network-id 20280
 ip nhrp nhs 10.202.96.1
 ip ospf network point-to-point
 ip ospf cost 5500
 tunnel source Dialer1203
 tunnel mode gre multipoint
 tunnel key 0
!
!
interface BRI0/0/0
 description ISDN 039 727 4904
 no ip address
 encapsulation ppp
 dialer pool-member 1
 isdn switch-type basic-net3
 isdn point-to-point-setup
 ppp authentication chap pap
!
!
interface Cellular0/2/0
 description GSM Link to IS
 ip address negotiated
 encapsulation ppp
 dialer in-band
 dialer pool-member 98
 ppp ipcp address accept
!
!
interface Dialer1203
 ip address negotiated
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 98
 dialer idle-timeout 0
 dialer string gsm
 dialer-group 98
 ppp authentication chap optional
 ppp ipcp address accept
 no fair-queue
 no cdp enable
!
}}}

* Tunnel setup
{{{
interface Tunnel082
 ip unnumbered Cellular0/0/0
 tunnel source Cellular0/0/0
 tunnel destination 10.10.240.tunnelIP

 ip ospf demand-circuit
 ip mtu 1400


}}}
Line 63: Line 171:
----
CategoryCisco

Cisco GSM 3G Setup

!
chat-script gsm "" "ATDT*99*1#" TIMEOUT 60 "CONNECT"
!
!
interface Cellular0/3/0
 ip address negotiated
 encapsulation ppp
 dialer in-band
 dialer pool-member 98
 ppp ipcp address accept
!
!
line 0/3/0
 script dialer gsm
 no exec
 speed 384000
!
!
interface Tunnel202
 ip address 10.202.80.89 255.255.240.0
 no ip redirects
 ip mtu 1440
 ip nhrp authentication cl20280
 ip nhrp map multicast dynamic
 ip nhrp map 10.202.80.1 10.202.240.2
 ip nhrp map multicast 10.202.240.2
 ip nhrp network-id 20280
 ip nhrp nhs 10.202.80.1
 ip ospf network point-to-point
 ip ospf cost 5500
 tunnel source Dialer1202
 tunnel mode gre multipoint
 tunnel key 0
!


#dialer-list 98 protocol ip permit
!
interface Dialer1202
 ip address negotiated
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 98
 dialer remote-name 3G
 dialer idle-timeout 0
 dialer string gsm
 dialer-group 98
 no fair-queue
 no cdp enable
 !!!! ppp authentication chap optional
 ppp ipcp address accept
!
ip route 10.202.240.0 255.255.255.0 Dialer1202 permanent name 3G-Tunnel-Endpoint
ip route 10.202.240.2 255.255.255.255 Dialer1202 permanent name 3G-Tunnel-Endpoint
!
  • debug

  debup chat
  debug ppp negotiation
  debug ppp event
  debug ppp error
  • Next example

!
track 1 interface Serial0/1/0 line-protocol
 delay up 180
pseudowire-class isgsm
 encapsulation l2tpv2
 ip local interface Cellular0/2/0
!
!         
interface Tunnel203
 ip address 10.202.96.143 255.255.240.0
 no ip redirects
 ip mtu 1440
 ip nhrp authentication cl20280
 ip nhrp map multicast dynamic
 ip nhrp map 10.202.96.1 10.202.240.3
 ip nhrp map multicast 10.202.240.2
 ip nhrp network-id 20280
 ip nhrp nhs 10.202.96.1
 ip ospf network point-to-point
 ip ospf cost 5500
 tunnel source Dialer1203
 tunnel mode gre multipoint
 tunnel key 0
!
!         
interface BRI0/0/0
 description ISDN 039 727 4904
 no ip address
 encapsulation ppp
 dialer pool-member 1
 isdn switch-type basic-net3
 isdn point-to-point-setup
 ppp authentication chap pap
!   
!         
interface Cellular0/2/0
 description GSM Link to IS
 ip address negotiated
 encapsulation ppp
 dialer in-band
 dialer pool-member 98
 ppp ipcp address accept
!
!         
interface Dialer1203
 ip address negotiated
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 98
 dialer idle-timeout 0
 dialer string gsm
 dialer-group 98
 ppp authentication chap optional
 ppp ipcp address accept
 no fair-queue
 no cdp enable
! 

* Tunnel setup

interface Tunnel082
 ip unnumbered Cellular0/0/0
 tunnel source Cellular0/0/0
 tunnel destination 10.10.240.tunnelIP

 ip ospf demand-circuit
 ip mtu 1400

...


CategoryCisco

Cisco/Gsm3G/Old2012 (last edited 2012-10-20 07:59:34 by dsl-244-102-175)